There are always questions popping up when trying to run software on lots of different system configurations. We’ll try and gather the most common ones here and keep it up to date with new ones when we see the need for it.

Is Nuke Indie supported?

Yes, Nuke Indie is supported from v.2.5.0. To have the plugin working in Nuke Indie you have to use the latest version available from Foundry of Nuke 12.2 or Nuke 13.0.

How are licenses consumed?

All of Pixelmania’s licenses are per host, i.e. you can have multiple jobs using NNSuperResolution on the same host and only use a single license. If you query the license server it may report multiple handles for those jobs, but it’s still only using a single license token.

Do you offer educational discount?

As of now, we are not offering any educational discount. We’ve chosen to sell our licenses for a low price instead to accommodate most people and companies to afford a license anyway.

Am I able to transfer my NNSuperResolution license to another machine?

Yes, please fill out the License Transfer Form.

The form should be filled in, signed, scanned and emailed to licenses@pixelmania.se, and we will send you a new license file as soon as we can.

Do you really need CUDA installed to be able to use the GPU?

We understand that there are situations where you might not be able to install CUDA on the workstation you want to run NNSuperResolution on, not having administrative permissions could be one such reason. There are ways around this since what the plugin is actually needing are a bunch of dynamic libraries from the NVIDIA CUDA toolkit and the NVIDIA cuDNN toolkit. You can download these toolkits from NVIDIA and simply copy these library files to the same directory as the installed plugin, and it will find them when needed. To make this easier for you we also provide downloads of NNSuperResolution with these needed NVIDIA libraries bundled into the same zip archive. You can then directly install the whole content of the zip into a NUKE_PATH of your choice and things will just work.

For reference, this is a list of the library files that you need for running the CUDA10.1 compatible version of NNSuperResolution:

  • libcublasLt.so.10
  • libcublas.so.10
  • libcudart.so.10.1
  • libcufft.so.10
  • libcurand.so.10
  • libcusolver.so.10
  • libcusparse.so.10
  • libnvrtc-builtins.so
  • libnvrtc.so.10.1
  • libnvToolsExt.so.1

There might be other versions of the files above for other CUDA toolkit versions, but the base names should be the same.

You can download the CUDA toolkit from NVIDIA’s website here: 

https://developer.nvidia.com/cuda-downloads

You also need these files from the NVIDIA cuDNN package:

  • libcudnn_cnn_infer.so.8
  • libcudnn_ops_infer.so.8
  • libcudnn.so.8

You can download the cuDNN package from NVIDIA’s website here:

https://developer.nvidia.com/cudnn

You do, always, need a good and modern version of the NVIDIA graphics driver installed and working to be able to use your NVIDIA GPU.

You can download the latest graphics drivers from NVIDIA’s website here:

https://www.nvidia.com/Download/index.aspx

What NVIDIA graphic card architectures are supported?

The currently supported CUDA architectures are the following compute capabilities (see https://en.wikipedia.org/wiki/CUDA):

  • 3.5 (Kepler)
  • 5.0 (Maxwell)
  • 5.2 (Maxwell)
  • 6.0 (Pascal)
  • 6.1 (Pascal)
  • 7.0 (Volta)
  • 7.5 (Turing)
  • 8.0 (Ampere)
  • 8.6 (Ampere)

We have now released a version of NNSuperResolution that does support the most recent NVIDIA graphics cards (RTX30xx GPUs, for example RTX3070, RTX3080 and RTX3090). Please head over to the Downloads page, and look for the version that is compiled against CUDA11.2.

Why is the plugin so large?

This is a result of including a lot of needed static libraries for neural network processing, and also for supporting lots of different graphic cards for acceleration. The plugin could have been much smaller if all these pieces of software used were required to be installed as dependencies on the system instead. That would kind of defeat the nice ecosystem of having self contained plugins that work simply by themselves, hence the plugin need to be a rather large file.

I’m having problems running NNSuperResolution in the same Nuke environment as KeenTools FaceTracker/FaceBuilder

We have noticed that trying to load both NNSuperResolution and FaceTracker in the same Nuke environment makes the plugins clash with each other. The error you get is that NNSuperResolution is not finding the GOMP_4.0 symbols in the libgomp.so shared library that is loaded. This is because both NNSuperResolution and FaceTracker are using the libgomp.so shared library, but KeenTools have decided to ship their plugin with a version of this library. This specific library version they are shipping is a rather old version of the library. So what happens is that NNSuperResolution is trying to use the version from FaceTracker but it’s expecting a newer version, and it’s then failing. The fix we have found working well is simply to delete the libgomp.so file that is shipped with KeenTools. You probably already got a newer libgomp.so file installed on your system. If that is the case both NNSuperResolution and FaceTracker will pick up the newer libgomp.so shared library from the system, and since this library is backwards compatible everything will just work nicely. If you haven’t got libgomp.so installed on your system, you need to install it to run the plugins. How that is done is of course dependent on your operating system and such. On CentOS you can install it by simply running the command “yum install libgomp“.